Jump to content

Wine patch for PSOBB on Linux and Mac


Recommended Posts

Hey, I'm new to the Wine app and all this jazz unfortunately have realized I have no idea what I'm doing. Is there anyway you could dumb it down for me lightly as I have no idea how to nab the wine sources or anything of the sort to get this stupid patch to work?

I've read the detailed instructions on the second page, but unfortunately my desperate research has not turned into results. I feel like I am either making things too complicated, or I just straight up don't have what I need to do this.

Link to post
Share on other sites
  • 4 weeks later...
  • Replies 127
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hey everyone, I'm not a player on this server (yet?), but seeing as how the PSOBB community has fragmented a bit I should probably share this with y'all too. I investigated the bursting screen cr

Yes, you can play Ultima Server on Mac and Linux with this code patch. [Google Translate] Sí, usted puede jugar Ultima Server en Mac y Linux con este parche para el código.

HALLELUJAH. IT WORKS. Better make this a pinned fix to linux mate, because you are a savior.

You need to intall wine and then there's a link to patch it, after should follow those instructions, sadly i don't know much about macs.

Sent from my XT1068 using Tapatalk

Link to post
Share on other sites
  • 3 weeks later...

Ok will build a little guide here for the users who have problems. I will try to be as clear as I can but there will be steps that will require you to research a little bit.

We have to assume that if you are in the Linux world you know how to do certain things and since I don't own a Mac Computer this guide will be aimed and supported for Linux users.

So far I have tested the patch in three different computers all of them with different hardware and with two different Linux distributions and it worked in all of them.

LinuxMint 17.1 and OpenSuse Leap 42.1

First we need to download the necessary files and of course the patch that we need here .

For the wine part I recommend to install Wine using your package manager, this will install all needed requirements for wine, just make sure you install version 1.7.x or 1.8.x. I used 1.8. (install a stable one not a beta one) Or you can install it from source, it makes no difference (I have tried both) but will take more time installing from source.

---!!IMPORTANT if you installed using your package manager double check which version of Wine you installed and make sure you download the source to the closest version to match your wine installation.

Download the source, extract it and put the file patch in the root for the source.

Apply the patch to the source with command

Open the terminal inside the directory of the source and apply the patch using command

patch -p1 < psobb-mipmap-patch.patch

next run command

./configure

wait for it to finish it might take some time since its configuring the source for your specific distribution and hardware.

finally run the last command.

make dlls/d3d8 dlls/wined3d

It will start to generate the files and more things that I don’t really understand XD.

After it finishes you will find the needed dlls in the source dlls folder. Go to folder d3d8 and take the file d3d8.dll.so and copy to your PSO root folder, remove the .so extensions and do the same for the wined3d one.

Once installed try to run PSO and it should work, if it does not work, run PSO using the console so you can see the error.

And that's it guys, the hardest part was done from the developer of the patch who we give the entire credits for this.

Thanks.

Extra Tips

Sometimes Wine does not give you the entire list of fonts that your use to see in windows. this is because Microsoft copyright and your distribution. To fix this issue use "winetricks" to install all MS fonts. Winetricks can help you in other aspect of wine too. Its a very helpful tool that i really recommend. You can find more info for it in the official site https://wiki.winehq.org/Winetricks

Notes: So far the only thing that i haven't be able to make work is Soly's Launcher this is because the launcher needs Net Framework 4, and even tho i have framework 4 installed not all applications are compatible with wine/framework.

if someone is able to make the New launcher to work in linux pc please let us know.

Thanks.

Look At next post for launcher info.

screenPSO_LarvaLinux.png

Edited by Soly
Link to post
Share on other sites

Larva has 3000 hp, confirmed hacker. Plz ban

LOL if im banned the ship will be down. its linked to my account :P

Link to post
Share on other sites
  • 2 weeks later...

Update..

I did so many changes to my Wine setup and at the i dont know if was something i did or something Soly did in his latest update of the launcher. (I will confirm this using another computer later on.) But anyhow the Soly's launcher is working and all it's features are too.

My current wine Setup is the one mention in the post above + framework 4.5 installed with winetricks. Winetricks also installed by itself previous versions of framework. Just select to install 4.5 and it will do the necessary files.

The only error that i notice it's that the update dont work at first launch, just keep pressing Retry until it check the updates if updates are need to download it will download. If not then will close.

launcher1.png

Link to post
Share on other sites
  • 1 month later...

Is there anyone who can confirm if this still works for mac? I'm trying to get my Brother to play and he is on Mac.

I don't have Mac, but I can confirm that everything still work in Linux , even de new launcher. When u try this make sure you use the latest installer of ultima .

Sent from my Nexus 6P using Tapatalk

Link to post
Share on other sites
  • 2 weeks later...

Ok will build a little guide here for the users who have problems. I will try to be as clear as I can but there will be steps that will require you to research a little bit.

We have to assume that if you are in the Linux world you know how to do certain things and since I don't own a Mac Computer this guide will be aimed and supported for Linux users.

So far I have tested the patch in three different computers all of them with different hardware and with two different Linux distributions and it worked in all of them.

LinuxMint 17.1 and OpenSuse Leap 42.1

First we need to download the necessary files and of course the patch that we need here .

For the wine part I recommend to install Wine using your package manager, this will install all needed requirements for wine, just make sure you install version 1.7.x or 1.8.x. I used 1.8. (install a stable one not a beta one) Or you can install it from source, it makes no difference (I have tried both) but will take more time installing from source.

---!!IMPORTANT if you installed using your package manager double check which version of Wine you installed and make sure you download the source to the closest version to match your wine installation.

Download the source, extract it and put the file patch in the root for the source.

Apply the patch to the source with command

Open the terminal inside the directory of the source and apply the patch using command

patch -p1 < psobb-mipmap-patch.patch

next run command

 /.configure 

wait for it to finish it might take some time since its configuring the source for your specific distribution and hardware.

finally run the last command.

make dlls/d3d8 dlls/wined3d

It will start to generate the files and more things that I don’t really understand XD.

After it finishes you will find the needed dlls in the source dlls folder. Go to folder d3d8 and take the file d3d8.dll.so and copy to your PSO root folder, remove the .so extensions and do the same for the wined3d one.

Once installed try to run PSO and it should work, if it does not work, run PSO using the console so you can see the error.

And that's it guys, the hardest part was done from the developer of the patch who we give the entire credits for this.

Thanks.

Extra Tips

Sometimes Wine does not give you the entire list of fonts that your use to see in windows. this is because Microsoft copyright and your distribution. To fix this issue use "winetricks" to install all MS fonts. Winetricks can help you in other aspect of wine too. Its a very helpful tool that i really recommend. You can find more info for it in the official site https://wiki.winehq.org/Winetricks

Notes: So far the only thing that i haven't be able to make work is Soly's Launcher this is because the launcher needs Net Framework 4, and even tho i have framework 4 installed not all applications are compatible with wine/framework.

if someone is able to make the New launcher to work in linux pc please let us know.

Thanks.

Look At next post for launcher info.

screenPSO_LarvaLinux.png

can you tell me if this works in ubuntu i abanoned mint becuse i couldent up date some how it failed to update the next day after installing 175 gb of steam games

also i should add i tryed meny times to get it runing on mint and failed

UPDATE iv found open suse and im going to try that no need to look over ubuntu ill try going over what you posted in suse and hope it works

Edited by Samuel Oyler
Link to post
Share on other sites

tested using wine 1.7.52 in opensuse leap 42.1 x64 and the patch works great. Thanks for making this patch available to everyone.

heres a screenshot running from my laptop.

http://postimg.org/image/hd5i91q9x/

thank you for your hard work i now have psobb runing in linux if u can do it im sure any one can ! thank you very much

Link to post
Share on other sites
  • 2 weeks later...

Yo! Not sure if I'm even remembered, but I was that dude that used to play on Ultima, was a chill mang who's alts were named something around Zeromir or Zer0. I stopped playing as I had to focus a lot on school, and I got a laptop working that has Ubuntu on it. I'm curious as to whether this patch can work on Ubuntu, and if it can, a really quick tutorial/run-down on how to get it working would be much appreciated. I'm totally terrible at coding things and using Linux cmd and Wine, as it took me about three days to get a simple tutorial on installing a WoW Vanilla server correctly.

 

Also, yes, post is a bit old, but I've been looking everywhere. Good to know fellow Ultima players want Linux!

Link to post
Share on other sites

 well i got it working for me it was Ubuntu thats what i used to run it  you should install the new wine the unstable one do it in terminal not with the soft where app they give you

if this dosnt work try 8 not 9 for wine but that worked for me there was some other like settings but im unsure what got it to run as it is now i have the files and thro a new bild of Ubuntu docent run psobb in linux my copped files of the programming folder from the time it did work still runs on a new install  im not sure how i can give you the files but ill up load them some where if you cant get it working and you can tell me if they work for you its run stable there are some bugs but ill talk with you in game once its running.

 

im kind of bin busy in life lately but ill try to cheack latter to see if there is any more i can do or a place to up load that  as i said im not sure why that programing folder works for i all i know  i just got lucky

 this is a screen shot of it running i wish you luck ill help you if i can

SPQ3Ebm.jpg

 

Edited by Samuel Oyler
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...