Jump to content

PSO thinks my up arrow key is held down at all times?


Recommended Posts

Well I really can't figure this one out. PSO was working great for me before, but I ran into issues when I reinstalled Windows 10 and went to play PSO again. Now, every time I get to the character select screen, the game thinks my "up" arrow is held down. This of course results in having to play roulette with the menus in the game. What's weird is that this glitch only affects PSO, it's only within the menus, it only happens once I get to the character select, and I've already tried doing a fresh install of PSO. 

Any ideas??

Link to comment
30 minutes ago, Cyane said:

try to check if the drivers for that gamepad are updated

That didn't do it unfortunately... I even tried uninstalling the Xbox 360 controller driver, restarting, then reinstalling it, I tried unistalling PSO, restarting, then uninstalling that as well. I can't figure out what on earth is going on. I'm like tempted to try a fresh install of Windows 10 at this point.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...