Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Sign in to follow this  
midatou

solved [solved] Help running Launcher on Kubuntu 18.04.1

Recommended Posts

Hello!

Long time PSO/PSOBB fan/player here, coming to join this server because I can't remember my login info on another server that is less populated.

I just got rid of my Windows 10 install and managed to get this to run on Kubuntu, the only issue so far is that I am having trouble getting the launcher to run which means I am unable to adjust the settings of the game.

Is anyone experienced with getting the launcher to run in a non-windows environment? I've tried adding it into playonlinux but it keeps crashing. I've installed the framework in wine but it still isn't working. Any one have any suggestions? I can provide any info you may need.

Currently, the game runs fine if I run it by psobb.exe but the graphics are bad due to low resolution and I am unable to adjust the settings. I set window mode to off via wine-regedit to see if fullscreen works with my resolution, but I haven't tested it yet. Any ideas? Currently, no launcher.log is being produced -- either.  Any ideas?

Edited by midatou
Solved.

Share this post


Link to post
Share on other sites

Hello, ok first what version of Wine are you using.

also what version of net and how did install it. If the problem i'ts only the launcher then it's something with the net framework. Last time i tried to use the launcher in my linux box i had the same issue, hence i can't make changes to the settings. It's the reason ill sugges we should have a text base or command line settings for linux users like me lol. Maybe we can get that in a future. in the meantime ill keep trying the launcher and ill get back to you.

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Larva said:

Hello, ok first what version of Wine are you using.

also what version of net and how did install it. If the problem i'ts only the launcher then it's something with the net framework. Last time i tried to use the launcher in my linux box i had the same issue, hence i can't make changes to the settings. It's the reason ill sugges we should have a text base or command line settings for linux users like me lol. Maybe we can get that in a future. in the meantime ill keep trying the launcher and ill get back to you.

Okay!

I am using Wine 32bit version and Playonlinux says I have Wine 3.19 installed. Is there a particular version I should have for PSOBB? (I don't have a 64bit version installed)

POL version is 4.2.12

The .net is all of the versions, I guess, because when I installed it via Playonlinux it acted like it installed all of them. I installed 4.5 (then tried the others like 4, 3/etc) but none of them work.

Oh, also I am running POL windows emulation under Windows XP (I've also used Windows 7).

I'm not even sure if the .net framework installation was successful or not. But earlier today when I was messing with it, I at the very least got Wine Debugger window to open when I try to run launcher, rather than merely nothing happening and a crash warning from POL. I suppose, as long as the graphics are withstand-able, I can just play in fullscreen, but ideally I would like to adjust my settings.

I agree, a text config file would eliminate this problem (which I searched the directory for, over and over -- wishing that it would magically appear even though I know it won't -- lol).

 

Keep me posted. I plan on doing my usual thing, farming lots and raising mags, probably run a PD shop if that is a thing on Ultima.

Edited by midatou

Share this post


Link to post
Share on other sites

Ok returning to this.

Well i came back to my linux box and got the launcher working. This is what i had to do.

For some reason Net Framwork work better with other version of wine. So i unistalled my wine installation and also removed the configuration folder after the uninstall and then i proceed to install the version of wine "wine-staging" this version contains developers and some testing plugins.

ok so after installing wine-staging i make sure to set the wine enviroment to work only as 32bits system since net framework works better in to 32bits one. I did that with the following command, wait before running this command make sure to delete the configuration directory of wine with "rm -r .wine"

then run this for the 32bit enviroment

WINEARCH=win32 WINEPREFIX=~/.wine wine wineboot

then I installed Net Framework using winetricks with the following line.

$winetricks dotnet40

that will install netframework 4, im using wine in Windows Xp enviroment and the launcher works just fine with the above process. Note that i dont use playonlinux and never used before so no idea about that.

 

Screenshot_20181107_194050.png

  • Like 2

Share this post


Link to post
Share on other sites

Would you mind trying to figure it out with Playonlinux? I want to use it as it makes it easy to create virtual windows drives that have their own purposes.

But, if I have to remove wine and reinstall it, I suppose I can do that.

 

Installing wine-staging right now. I'll see if I can get it to work your way.

Edited by midatou

Share this post


Link to post
Share on other sites
1 minute ago, midatou said:

Would you mind trying to figure it out with Playonlinux? I want to use it as it makes it easy to create virtual windows drives that have their own purposes.

But, if I have to remove wine and reinstall it, I suppose I can do that.

As far I know, playonlinux runs over wine, so I guess you still need to change the wine version and then use playonlinux with Wine-staging? Try that and let us know.

Thanks 

Share this post


Link to post
Share on other sites
On 11/8/2018 at 1:41 PM, Larva said:

As far I know, playonlinux runs over wine, so I guess you still need to change the wine version and then use playonlinux with Wine-staging? Try that and let us know.

Thanks 

Okay.

Yeah, that was probably my issue. I didn't have wine-staging or winetricks installed.

Winetricks is installing dotnet40 now. Should work.

 

Edit: Hmm, still crashing. Maybe I should uninstall playonlinux?

 

What version of Wine are you using, anyway?

 

EDIT:

 

WOO! I finally got it to work. I had to fully remove all of the wine's I installed and try again. I got it to work with q4wine and now the launcher works fine! Hooray.

Thanks for the help. I couldn't of done it without you reminding me of winetricks and dotnet40. Expect me to be on!

Edited by midatou
Solved.
  • Like 2

Share this post


Link to post
Share on other sites

Nice to see you got it working! congratz! see you in game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×