Jump to content

Recommended Posts

Hi all,

Got the itch after about a year, so I figured I'd fire up PSO for a bit. I've already heard about the new weapons and the name difference and whatnot, so I'm trying to run the Launcher to update the game. Problem is, I'm on a Mac, so I'm using wine, and Launcher.exe won't open:

Brads-MacBook-Pro:Ultima PSOBB bradorego$ wine Launcher.exe 
Wine cannot find the ncurses library (libncurses.5.4.dylib).
The entry point method could not be loaded

I've done some googling and tried to install ncurses via homebrew, but that didn't seem to get me anywhere.

Anyone else run into this?

Link to comment

Well, I'm assuming you have already did the setup for wine to open psobb properly ( https://www.phantasystaronline.net/forum/index.php?/topic/24378-wine-patch-for-psobb-on-linux-and-mac/ ), but if for some reason it's just the launcher you can't open, you can always download the latest update from the downloads page. Once you have the latest update then item names should work properly (whenever we add new items, then names get shifted around) Here:  http://www.ultimapsobb.com/psobb/update/update.7z


Link to comment

Ooooh, yeah, I totally forgot about that.

Hmm. The game was running fine, but all the item names were messed up. I just downloaded the update and overwrote my former psobb.exe and now it doesn't work at all :( Maybe I'll just start with a fresh install.

Link to comment

I can't get Launcher.exe to work on my Mac.

BUT! By downloading the update manually and then copying the updated data folder and psobb.dll it seems to have fixed itself!

Link to comment

I just realized option.exe is missing, which means I can't do things like change resolution or save my account info. Help?

Link to comment

You need net framework to run the launcher.
Try to install that, if you cant, I can give you a registry file so you can import some options...

I'll see if I can make a registry file generator for when you can't use the launcher (there are many options that weren't in the old online.exe anyway)

Link to comment

Installed .NET and it didn't seem to matter :(

As the original post states, it seems that the issue is ncurses, whatever that is. My basic google searching points to either my machine doesn't have that particular library, or my installation of wine can't find it.

Link to comment
3 minutes ago, Soly said:

Weird that should be working then.
I really don't know what that ncurses lib stuff is.

It's a curse :cr-flying:

  • Like 1
Link to comment

Oh, yeah, I'm 90% sure it's a weird OSX issue, but I was hoping by posting here that either somebody had already run into this and had an easy fix, or that @Soly might be able to provide enough background knowledge of what Launcher is/does to figure it out :)

If there was a way to manually set whatever property flags option.exe does, I'll gladly do that, but I'm guessing it's all hex or something so I probably can't just jump into a config file and start editing.

Link to comment

option.exe is deprecated (as you can see is not even in the updates anymore).
The launcher does it all.

As I said, I am working in a page where you will be able to generate a .reg file that you can import into wine's registry.
This will set all the options you want without making use of the launcher, obviously it would be better if the launcher worked but I couldn't find anything about that ncurses thing.

If you want the quick exit (for now) I can give you a file made manually, just tell me what sort of options you'd like resolution, fullscreen or windowed, graphic options in high or low (i'd recommend low if playing in wine), etc.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...